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Developed by the NOAA Center for Tsunami Research (http:/nctr.pmel.noaa.gov)
in collaboration with the International Tsunami Information Center (http://itic.ioc-unesco.org)

TsuCAT information is available from http://itic.ioc-
unesco.org/index.php?option=com_content&view=category&layout=blog&id=2239&Itemid=2763

Application specific questions and bug reports should be directed to:
http://nctr.pmel.noaa.gov/TsuCAT

Scenario based hazard assessment available through TsuCAT is primarily intended to support pre-
event tsunami response planning and exercise development. During an event, TsuCAT may assist
in early situational awareness (approximate scenario) prior to the availability of event-specific
forecasts from national agencies or international tsunami service providers.
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ABSTRACT

The Tsunami Coastal Assessment Tool (TsuCAT) is a simple and quick, yet powerful
tool for exploring the impact from many different tsunamis. It was developed by the
NOAA Center for Tsunami Research (NCTR) to support the International Tsunami
Information Center’s (ITIC) effort to provide countries with tsunami decision support
tools.

TsuCAT provides access to a Pacific database of tsunami modeling results from NOAA’s
pre-computed catalog of sources (Propagation Database) to assist a country in its tsunami
hazard assessment, tsunami exercise and response planning, and warning decision-making.
Simulations for historical tsunami sources from NOAA’s National Centers for
Environmental Information (NCEI) and the U.S. Geological Survey earthquake archive are
also included.

During an event, national tsunami warning centers must be able to assess their threat, and
decide when to issue warnings based on their own alert level criteria. For earliest decision-
making, especially for local tsunamis, a pre-computed, look-up database containing
plausible warning scenarios and thresholds is often used. TsuCAT may assist in early
situational awareness (approximate scenario) prior to the availability of event-specific
forecasts from national agencies or international tsunami service providers

TsuCAT is platform independent and ‘stand-alone’ in that it runs on the Microsoft
Windows, Apple Macintosh, and Linux computing platforms, and does not require Internet
connectivity. All libraries, databases, and documentation are installed in their entirety on
the host machine. The only requirement is a Java v1.8 or higher free installation

Offshore maximum tsunami wave amplitude and arrival time are easily queried on the
map. The generated map also provides Coastal Hazard Guidance, which is represented as
the deep-ocean wave amplitude extrapolated to the coastline accounting for shoaling
using the Green’s Law approximation. A Coastal Hazard ‘Warning’ Polygon map layer
is included, which is equivalent to the Pacific Tsunami Warning Center’s Coastal
Tsunami Amplitude Forecast Polygon map, and also customizable. An exercise tool is
available to generate the PTWC test messages and enhanced graphical products for use
during tsunami exercises. The user is cautioned that when using real events from the
event database that the test messages and enhanced graphical products produced will be
based only on the closest source in the TsuCAT catalog and, hence, may not exactly
match the PTWC-issued forecast. The feature is meant only to assist in tsunami
exercises.
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1. Introduction and Background

In 2014, the U.S. Pacific Tsunami Warning Center (PTWC) ceased provision of watches
and warnings for countries throughout the Pacific Ocean. Enhanced products that include
wave amplitude were developed and are now provided to offer forecast guidance. The
2014 change now requires countries to be responsible for assessing their own threat, and
deciding when to issue warnings based on their own alert level criteria. In an effort to
assist countries in their decision making, the International Tsunami Information Center
(ITIC) and NOAA Center for Tsunami Research (NCTR) developed the Tsunami Coastal
Assessment Tool (TsuCAT) that was distributed to delegates to the Twenty-seventh
Session of the Intergovernmental Coordination Group for the Pacific Tsunami Warning
and Mitigation System (ICG/PTWS-XXVII, March 28-31, 2017)

TsuCAT provides access to a global database of tsunami modeling results from NOAA’s
pre-computed catalog of sources (Propagation Database, GICA ef al., 2008), and from
NOAA’s RIFT model, to assist a country in its tsunami hazard assessment, tsunami
exercise and response planning, warning decision-making, and education and outreach.
Simulations for historical tsunami sources from NOAA’s National Centers for
Environmental Information (NCEI) and the U.S. Geological Survey earthquake archive
are also included. The tool is a ‘standalone’ application not requiring the Internet, and
can be used for outreach in remote locations, as well as during events when
telecommunications are down.

TsuCAT assists countries in response planning and preparedness by providing a tool that
enables planners to determine where the worst case tsunami sources are located, how big
the earthquake’s magnitude must be to directly threaten their coastlines, how much time
they will have before the first tsunami wave hits, and how big the tsunami wave is
expected to be. This information can then be used to develop tsunami emergency
response and evacuation plans, and to conduct tsunami exercises that will prepare
response agencies and communities to be ready for the real event. TsuCAT will create
the PTWC text and enhanced graphical products that can be used for tsunami exercising.

TsuCAT can also assist national tsunami warning centers with early situational awareness
(approximate scenario) prior to the availability of event-specific forecasts from national
agencies or international tsunami service providers. As TsuCAT is a pre-computed
database of plausible tsunami scenarios with customizable coastal hazard warning
polygons, it could be useful as a look-up tool to provide a conservative assessment prior
to PTWC tsunami forecasts (typically 30 minutes after the earthquake due to the time
required to reliably characterize the earthquake source).

This manual introduces the user to TsuCAT and describes the workflow and parameters
necessary to access all functionality offered through the application.
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2. Application Overview

TsuCAT is a platform-independent application that was developed for hardware running
Windows, Macintosh, and Linux operating systems and depends only on a Java
installation (version 1.8 or higher). A graphical user interface gives access to NOAA’s
Database of pre-computed tsunami arrival times and maximum amplitudes. In this
software release, the Database is populated with results of modeling with the MOST
model for magnitudes greater than Mw > 8.0 and with the RIFT model (used by PTWC)
for magnitudes less than Mw < 8.0.

The Database contains results from more than 2000 model runs of the tsunami
propagation Method of Splitting Tsunamis (MOST) code and PTWC’s Real-time
Inundation Forecast of Tsunamis (RIFT) code. PTWC uses both models to calculate
tsunami forecasts for countries in its international areas of responsibility (Pacific and
Caribbean). Information on RIFT can be found in the Users Guide for the Pacific
Tsunami Warning Center Enhanced Products for the Pacific Tsunami Warning System
(IOC Technical Series No 105, Revised edition. UNESCO/IOC 2014 (English; Spanish),
and information on MOST can be found in /mplementation and testing of the Method of
Splitting Tsunami (MOST) model (NOAA Technical Memorandum ERL PMEL-112, 11

pp)-

The MOST model runs form the basis of the Short-term Inundation Forecasting of
Tsunami (SIFT) and are comprised of an initial thrust deformation on a standard 100km-
by-50km fault plane, and use seismic parameters appropriate to the hypocenter selected,
with a slip value of 1 meter. This 1-meter slip value gives them the name “unit sources”,
and produces a moment magnitude (Mw) of 7.5 for each of the fault planes. These pre-run
models have been combined to represent earthquakes of larger magnitudes, and the wave
amplitude for various combinations can be shown to the user to allow assessment of wave
amplitude at any given location in the ocean basin. While the standard 100km-by-50km
fault plane works well for forecasting larger magnitudes using SIFT, magnitudes below 8.0
have been run using the RIFT model with fault lengths decreasing appropriately with
magnitude. This allows accurate results over a range from Mw 6.5 up to the theoretical
maximum of 9.6.

Various ways exist to extrapolate offshore wave amplitude values to the coastline to
account for shoaling, and the “Coastal Hazard Guidance” algorithm allows a very rapid
assessment of hazardous areas along a regional coastline given only earthquake magnitude
and epicenter location.

TsuCAT allows the user to view the effect of an earthquake at any location along a
coastline using the Propagation Database by calculating the maximum wave amplitude
for various combinations of unit sources using the relationships between rupture length
and magnitude as outlined in Wells and Coppersmith (1994). Over 5,400 combinations
are pre-calculated for magnitudes from Mw=6.5 to 9.6 in increments of 0.3, for all three
major ocean basins: Pacific, Atlantic (including the Caribbean), and Indian. As of
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version 4.0, the scenarios cover the South China Sea and marginal seas of the Western
Pacific.

The full installation of TsuCAT includes a/l the combination files, and, therefore allows
TsuCAT to run “stand-alone”, without an Internet connection. Archives of coastline and
historic earthquakes are also provided, allowing the user to search nearby tsunamis and
magnitudes to make an accurate assessment of the hazard due to a tsunami for a given
stretch of coast. If the user has an Internet connection, new earthquake information is
automatically queried from the USGS earthquake archives each time TsuCAT is run.
This means that newly occurring events are available in near real-time. Rendering the
pre-run offshore wave amplitudes using the closest scenario to the desired epicenter takes
only moments, so a rapid assessment for guidance is possible.

2.1 Workflow

TsuCAT was designed for a user to easily and quickly get a baseline feel for the possible
impact of a tsunami along their Pacific coastline of interest. An earthquake source from
which to generate the tsunami is first selected either from a list of historical events or by
choosing one or a combination of NOAA propagation database unit sources. Once
selected, the workflow consists mainly of visualization choices, examples of which are
shown in Figure 1.

® - )

*‘ il e .4 :

Access 10 a suite of The source of an arbitrary tsunami  Display of coastal Custom warning polygons for

features for viewing is selected from the NOAA hazard guidance based detailed hazard guidance at the Map Tiles
tsunami guidance is i on Green's Law local or community level.
provided from the historical event can be selected

main graphical user from a list.
interface.

Figure 1: The TsuCAT workflow. Once an earthquake source is selected, the user has
options to visualize the impact on large and small scales.
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3. The NOAA Propagation Data Base

A pre-computed tsunami propagation database, that consists of deep-water wave
elevations and flow velocities pre-computed for a continuous series of 50 x 100 [km] unit
sources along all known subduction zones within each ocean basin, provides the sources
used to construct the offshore wave amplitude database. Gica et al., (2008) provide
details of database generation using the MOST model, including design and seismic
considerations. This database is augmented with offshore wave amplitudes from the RIFT
model for moment magnitudes less than Mw 8.0, where 50 x 100 [km] faults planes are
too large. The RIFT results are created using the same epicenter locations as the MOST
results, but appropriately smaller length, width, and slip parameters. The tsunami source
approximates a shallow thrust fault earthquake. The database unit sources can be linearly
combined to produce synthetic boundary and initial conditions of water elevation and
flow velocities to initiate tsunami forecast computations.

4. Graphical User Interface and Features

4.1 Overview

When TsuCAT is first opened (double-click the application icon), the main graphical user
interface window comes up with the offshore wave amplitude [cm] and wave arrival time
[hours] for the Great Japan Tsunami of 11 March 2011 shown by default (Figure 2).

eoe Tsunami Coastal Impact Tool version 4.2
File Edit View Help

Requested Epicenter, Lat:  38.29700 Lon: 14237200 Closest in Catalog, Lat: 38.29700 Lon: 14237199 (0 [km] away)

@ TsuCAT

Mw: 9.10 Event: 11 Mar 2011 05:46:00 (UTC) Mw: 9.1 Ep: 38.297° N, 142.372° E Dep: 30.0 [km] "JAPAN"

I 1 Offshore Wave Ampl. [cm] " i N
~Z Travel Time [hrs]

@ Earthquake Epicenters

'r Requested Source Epicenter
@ PropDB Catalog Epicenters
{J Tsunami Observations
& Plate Boundaries
71\ Coastal Hazard Guidance
@ Place Names
@@ User-supplied Maps [2]
€3 Warning Polygons

Midway Is.

Wake I.
Johnston Atoll

PTWC Polygons
Custom Polygons Magshal Is.

Kiribati
Jaruls .

Tuvalu

Tokelau Nuku Hiva

'Samoa French Polynesia
Tahiti Coastal
Hazard
Guidance

H
/
Pitcaim Is. {’w Extreme

s3255

Niue  Cook Is.

60
50
20
] 30
T High 20
) 'S
~ Med a
]t
& 2
[ 'No Data ,“},
1 N o/
/ SR

Lon: 170.78342° W Lat: 24.85104°N Arrival. 5.73 [hrs] Offshore Ampl. 36.1 [cm| I Transparency:

Figure 2: The Tsunami Coastal Assessment Tool main interface.
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Event information is displayed in the top center panel, labeled “Event” (i.e., 11 Mar 2011
05:46:00 (UTC) Mw: 9.1 Ep: 38.297° N, 142.372° E "JAPAN"). Colors on the map,
from blue-to-yellow-to red, give a quick view of the tsunami maximum amplitude
throughout the Pacific Basin. Gradations of color are shown in a vertical color bar
plotted in the lower right-hand side of the plot frame. One-hour contours of wave arrival
are shown in black. Both offshore wave amplitude and expected arrival of the first wave
can be queried for any point by simply moving the mouse over the point of interest and
reading the value off the status bar at the bottom of the application. An example of the
status bar display is:

Lon 160.56940° W Lat 51.77936°S Arriva 14.31 [hrs Offshore Amp 5.1 [cn

The user can also pan and zoom the map in more familiar ways, either by click and drag
(pan) or by double-clicking (zoom), or by using these buttons in the upper left of the map
window:
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4.2 Propagation database unit sources

A clear star plotted on the map marks the requested epicenter of the earthquake that
generated the event of interest. Blue rectangles outline the Propagation Database ‘unit
sources.” Once selected, the unit sources are filled white, and are shown as the NOAA
Propagation Database codes with their respective weights, as used in the Short-term
Inundation Forecast of Tsunami (SIFT) forecast application as well and in the
Community Model Interface for Tsunami (ComMIT, TITOV ef al. 2011) inundation
model tool (Figure 3).

= ago

N

O] L]

~,

~
30-minute travel tim

MOST model e

Figure 3: The Propagation Database unit sources selected for the Great Japan tsunami of
2011.

In the case of the Japan 2011 event, empirical relationships between earthquake
magnitude, rupture length, rupture width and area, and surface displacement, known as
the Wells and Coppersmith relation (WELLS AND COPPERSMITH 1994) chose twelve unit
sources in a 2-by-6 configuration for a total fault area of 120,000 km? (200 km width and
600 km rupture length). The text representation for this source includes a weight and a
reference code for each unit source:

14.784*ki24a+14.784*ki24z+14.784*ki25a+14.784*ki25z+14.784*ki26a+
14.784*ki26z+14.784*ki27a+14.784*ki27z+14.784*ki28a+14.784*ki28z+
14.784*ki29a+14.784*ki29z
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These unit sources and their weights can be viewed by selecting the “View->Fault
Information” menu item in TsuCAT (Figure 4). The above text representation can be
copied-and-pasted by right-clicking on the table. A complete description of the
Propagation Database can be found in GICA et al (2008), and online at
http://nctr.pmel.noaa.gov/propagation-database.html. This text description can be used as
a source in the ComMIT inundation tool.

00 Seismic Info

Seismic Fault Plane Information:

MOST model run with 12 fault planes:

Fault combination (inversion):
14.7839*ki24b+14.7839*ki24a+14.7839*ki25b+14.7839*ki25a+14.7839*ki26b+14.7839*ki

Fault number: 1

Name: ki24b

Epicenter Longitude: 143.52730°
Epicenter Latitude: 40.31248°
Depth: 5.00 [km]

Length: 100.0 [km]

Width: 50.0 [km]

Slip: 1.000 [m]

Strike: 185.0°

Dip: 19.0°

Rake: 90.0°

Fault number: 2

Name: ki24a

Epicenter Longitude: 142.97950°
Epicenter Latitude: 40.34903°
Depth: 21.28 [km]

Length: 100.0 [km]

Width: 50.0 [km]

Slip: 1.000 [m]

Strike: 185.0°

Dip: 21.0°

Rake: 90.0°

Close

Figure 4: Unit Source table with weights showing the sources used from the Propagation
Database for the given event, as well as seismic parameters for the model run.
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4.3 Earthquake events, magnitudes, and epicenters

The epicenter for an earthquake (latitude and longitude of location) can be moved by
editing the “Requested Epicenter, Lat: Lon:” values, or by right-clicking the clear
epicenter star and dragging it (or “Command-click” on the Mac). It turns green when
dragged, and when dropped will find the epicenter for the closest unit source combination
in the Propagation Database catalog (Figure 5). Note that both the Requested Epicenter
and the Closest in Catalog epicenters are shown, along with the distance between them.

(=]

Os'—'”b@ﬂsggggs

P

Figure 5: An arbitrary Mw=9.1 along the Kamchatkai-Yap (ki) subduction zone.

The moment magnitude, Mw, can be edited in the upper panel text box labeled ‘Mw’ at
the top of the application window. Changes in Mw show how the impact to a coast might
change when smaller or larger tsunamis are generated. The larger the earthquake
magnitude, the greater the number of propagation database unit sources. An Mw=8.6 in
the same location along the Kamchatkai-Yap subduction zone selects only 6 unit sources,
instead of the 12 selected for the Mw 9.1 tsunami. Results from the smaller Mw show
correspondingly smaller maximum wave amplitude (Figure 6):
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i pesults=0
Figure 6: Arbitrary Mw=_8.6 along the Kamchatkai-Yap subduction zone.

Users can also turn on the “Earthquake Epicenters” layer by selecting it in the panel to
the left of the map. All historic tsunamis contained in the NOAA Center for
Environmental Information (NCEI/NGDC) Tsunami Database will be shown
(https://www.ngdc.noaa.gov/hazard/tsu_db.shtml) (NGDC, 2000 BC- present). This list
includes all events up through December 2019. Events after January 2020 may be
obtained from the USGS earthquake archive
(https://earthquake.usgs.gov/earthquakes/search/) and are refreshed each time TsuCAT is
launched, if an internet connection is found. The most recent vetting of a USGS event is
used each time the application is loaded.
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Represented as purple dots on the map (Figure 7) the size of the dot is scaled with the
size of the event. The user can select the closest epicenter to an historic event by right-
clicking on the event of interest and choosing from a list of nearby events:

[ JoX )

Date Mw ~ Latitude Longitude Count

1923-09-01 02:58
0818-08-01 00:00 7.9 35.200°N 139.300°E JAPAN

1495-09-12 00:00 7.1 35.100°N 139.500° E JAPAN

1433-11-07 00:00 7.1 34.900°N 139.500° E JAPAN

Tsunami Coastal Impact Tool version 4.2

File Edit View Help

@ TsuCAT

Requested Epicenter, Lat:  35.10000 Lon: 139.50000 Closest in Catalog, Lat: 34.38602 Lon: 138.19035 (144 [km] away

Mw: 7.90 Event: 01 Sep 1923 02:58:37 (UTC) Mw: 7.9 Ep: 35.100° N, 139.500° E Dep: 33.0 [km] "JAPAN"

v/ IF 1 Offshore Wave Ampl. [cm]
V| ~Z~ Travel Time [hrs)]

v/ @ Earthquake Epicenters

V! 7 Requested Source Epicenter
| @ PropDB Catalog Epicenters
O l Tsunami Observations
¥/ \ Plate Boundaries [2]

[ 7\ Coastal Hazard Guidance
| ® Place Names

| &mUser-supplied Maps

| €3 Warning Polygons

» v/ PTWC Polygons
» |V Custom Polygons

Lon: 130.86017° E Lat: 24.88009° N Arrival: 1.82 [hrs] Offshore Ampl: 4.6 [cm] I Transp y:

Figure 7: Historical tsunamigenic earthquakes (purple dots) from the Global Historical
Tsunami Database
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The selected event is then shown (Figure 8) with a red ring around the selected event, and
the selected event information is shown in the upper panel, including Epicenter, Mw,
Date/time, Depth and nearest country:

Requested Epicenter, Lat:  35.10000 Lon: 139.50000 Closest in Catalog, Lat:  34.38602 Lon: 138.19035 (144 [km] away)

Mw: 7.90 Event: 01 Sep 1923 02:58:37 (UTC) Mw: 7.9 Ep: 35.100° N, 139.500° E Dep: 33.0 [km] "JAPAN"

Figure 8: selected earthquake event

All earthquake epicenters can be viewed by choosing the menu item “File->Select Event”
(Figure 9). This table can be sorted by Date, Mw, Latitude, Longitude, or Country and
the selected event can be viewed in TsuCAT. TsuCAT will show the offshore wave
amplitude and Coastal Hazard Guidance for the scenario in its database with the closest
epicenter location and Mw of the event, scaling file to the Mw of the selected event.

[ BoN )

Date | Mw | Latitude Longitude Country

ZUI3=UZ=00 U117 .9 IU. 700 5 JOS. ITI8 F SULUMUNISCANDS A
2013-01-05 08:58 7.5 55.393°N 134.652° W USA

2012-12-07 08:18 7.2 37.890° N 143.949° E JAPAN

2012-11-07 16:35 7.3 13.988°N 91.895° W GUATEMALA

2012-10-28 03:04 7.7 52.788°N 132.101° W CANADA

2012-09-05 14:42 7.6 10.085° N 85.315°W COSTA RICA

2012-08-31 12:47 7.6 10.811°N 126.638° E PHILIPPINES

2012-08-27 04:37 7.3 12.139°N 88.590° W EL SALVADOR

2012-04-14 22:05 6.3 18.972° S 168.741° E VANUATU

2012-04-11 10:43 8.2 0.802° N 92.463"E INDONESIA

2012-04-11 08:38 8.6 2.327°N 93.063° E INDONESIA

2012-03-20 18:02 7.4 16.493° N 98.231°W MEXICO

2012-03-14 09:08 6.9 40.887° N 144.944° E JAPAN

2012-02-02 13:34 7.0 17.827°S 167.133°E VANUATU

2011-10-21 17:57 7.4 28.993°S 176.238° W NEW ZEALAND

2011-09-02 10:55 6.8 52.171°N 171.708° W USA

2011-08-20 18:19 7.0 18.311°S 168.218° E VANUATU

2011-08-20 16:55 7.1 18.365°S 168.143° E VANUATU

2011-07-10 00:57 7.0 38.034° N 143.264° E JAPAN

2011-07-06 19:03 7.6 29.539°S 176.340° W NEW ZEALAND

2011-06-24 03:09 7.3 52.050°N 171.836° W USA

2011-04-07 14:32 7.1 38.276° N 141.588° E APAN

2011-03-11 :

2011-03-09 02:45 7.5 38.435°N 142.842°E JAPAN
[2011-02-21 23:51 | 6.1 [ 43.583°S [ 172.680° E | NEW ZEALAND |v

Lo

Figure 9: Listing from the full earthquake database.




Tsunami Coastal Assessment Tool User’s Manual 20

4.4 Coastal Hazard Guidance

The Coastal Hazard Guidance (CHG) shown by TsuCAT represents the offshore wave
amplitude that has been extrapolated to the coastline using a simple-depth based
relationship to account for shoaling of waves. The relationship or approximation is given

by:
1/4
n=n (—H")
s — 'Id H

s

where Hq is the water depth at the deep offshore grid point, Hs is the water depth at the
coastal shoreline point and 7, is the wave amplitude at the shoreline approximated by the

deep-ocean wave amplitude 17,. The ratio of ocean depths, H, provides the scaling factor.

The MOST model was run with a bathymetric grid resolution of 4 arc-min, while RIFT
model runs were run with resolution that increases with smaller magnitude. This allows
resolving the smaller wavelengths generated by these smaller faults. Since the models
use varying resolutions, the depth chosen for the deep water point deepens with lower-
resolution runs and is known as the cutoff depth. For each point along the coastline, then,
the closest model grid point that is deeper than the cutoff depth is selected and scaled by
the ratio.

The Coastal Hazard Guidance (CHG) layer is viewed by selecting it in the left-hand
“layers” panel. This layer shows the Global Self-consistent Hierarchical High-resolution
Shoreline (GSHHS) coastline color-coded by the nearest offshore model point and scaled
to account for shoaling by the Green’s Law. Detailed information about the combined
shoreline, rivers, and geo-political boundaries GSHHS dataset is available at:
https://www.ngdc.noaa.gov/mgg/shorelines/gshhs. The resulting scaled shoreline value
is then colored in accordance with the color map. The CHG color map shows gray for
values that are less than 1 cm (essentially “no data”), green for values between 1-30 cm,
yellow for values between 30-100 cm, and red for values above 100 cm. The values for
the CHG bins can be changed in the TsuCAT Preferences as discussed in 4.7 Other
Features. The CHG takes a few seconds to calculate, so when the user changes the
magnitude or epicenter, TSuCAT calculates CHG in the background and renders the
colored shoreline values when calculations are complete. Coastal Hazard Polygons are
colored according to CHG, so they, too, take a few seconds to render if the user changes
the source selected.

The Coastal Hazard Guidance values tend to be larger than the adjacent offshore
maximum amplitude due to the scaling for shoaling, which is evident in Error! R
eference source not found.. Green’s Law was designed for estimation of channel flow,
so it provides the best coastal estimate where there are gently sloping bathymetries.
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eoce
File Edit Help

‘TSuCAT version 1.1.1

Epicenter, Lat: | 3820700 | Lon: | 142.37200

vn Tsunami Coastal Assessment Tool mw: [ o1 | event

Display Layers

11 Mar 2011 05:46:00 (UTO) Mw: 9.1 Ep: 38.297° N, 142.372" E Dep: 30.0 [km] JAPAN"

e N \
\

“‘ .531 '
W«

) &2 Warning Polygons e
Fa

> ¥ NOAA Polygons
¥ Custom Polygons v

& 5
|

@ r Nearest PropDB Epicenter

¥ 71\ Coastal Hazard Guidance
& B Countries
] # Place Names

Name Alpha
k242 20883
kiz4z 20883
kizsa 20883
kizsz 20883
kiz6a 20883
ki262 20883
ki27a 20883
k272 20883
kizsa 20.883

Lon: [136.75475°E | Lat [ 50.48090°N | Amival: [ NaNihrs] | Amp: [ NaNfem] | "

Figure 10: Coastal Hazard Guidance (CHG) based on Green’s Law scaling.

Green’s Law makes the following assumptions:
1. The coastline is linear and exposed to the open ocean.
2. Tsunami waves near the coast behave as one-dimensional plane waves.
3. There are no significant wave reflections and no dissipation by turbulence.
4. The bathymetry varies slowly compared to the wavelength of the tsunami waves.
Thus, for steep bathymetry, Green's Law can overestimate the wave amplitude.

5. CIliff boundary conditions are used. In other words, the coast is assumed to be a
vertical wall.

Specifically, the Green’s Law approximation breaks down in areas of complex
bathymetries. Therefore, where coastlines consist of bays, inlets, or are hidden by
offshore islands, or where the sea bottom rises steeply to the shore, Green’s Law coastal
wave forecasts will likely be in error.

Actual amplitudes at the coast may vary from the forecast amplitudes due to uncertainties
in the forecast and local features. In particular, maximum tsunami amplitudes on atolls
and at locations with fringing or barrier reefs will likely be much smaller than the Coastal
Hazard Guidance indicates. The offshore wave amplitude map should not be used to

estimate coastal tsunami amplitude or impacts. Deep-ocean amplitudes are usually much
smaller than coastal amplitudes.
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4.5 Coastal Hazard Polygons

The Coastal Hazard Polygons layer shows the NOAA Pacific Tsunami Warning Center
(PTWC) Coastal Tsunami Amplitude Forecast Polygons as colored by the TsuCAT
Coastal Hazard Guidance (CHG), with the following simple algorithm: the 99™ percentile
maximum of all coastal points within a polygon is used to color the entire polygon, e.g. if
the maximum CHG within a polygon is 67.2 cm, the entire polygon is colored yellow.
This aggregation tends to be a “broad brush” algorithm, as can be seen in Figure 11: areas
like the west coast of the United States and Canada that show mostly green and yellow
coastal values have polygons that are shaded red because of the few red coastal points.

eoce TsuCAT version 2.0

File Edit View Help

Epicenter, Lat: | 51.00007 | Lon: | 187.70019 |

vﬂ Tsunami Coastal Assessment Tool ww: | 890 | Event: ‘ ‘

[ Display Layers

™ I 1 Offshore Wave Ampl. [cm)
™ 2 Travel Time [hrs]

(] @ Earthquake Epicenters

™ 77 Nearest Source Epicenter
@] ' Tsunami Observations
(L) &~ Plate Boundaries

™ 7\ Coastal Hazard Guidance
(] ® Place Names

™ @@ User-supplied Maps (.shp)
™ €3 Warning Polygons

> @ PTWC Polygons
» ™ Custom Polygons

Lon: 173.97579° W Lat: 3.40230°N Arrival: 6.42 [hrs] Ampl: 11.5 [cm] T (] y: 0)

Figure 11: Coastal Hazard (Warning) Polygons for a hypothetical Mw=8.9 in the
Aleutian islands.
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4.6 Custom Coastal Hazard Polygons

TsuCAT gives the user the option to create their own coastal hazard polygons using the
menu item “Edit->Add Custom Warning Polygons”. To best use this option, the user
should zoom to the region of interest before starting. It is also a good idea to keep the
Coastal Hazard Guidance map layer selected. As an example, we will create a custom
polygon around the Republic of Vanuatu by zooming into the region and selecting the
menu “Edit->Add Custom Warning Polygon” (Figure 12).

g TsuCAT version 1.1.1
File Edit Help ece

Epi¢Set a unique name for this Custom Warning Polygon, then click on the map to form polygon.

@ . When finished forming polygon, click "OK".
v Tsunami Coastal Assessment Tool mw ... customasuicz -

onplytavers
I W Wave Amplitude [cm] <]
W Z Travel Time [hrs]
[ @ Earth
¥ [ Propagation Database
¥ Neares! t PropDB Epicenter
(¥ 71\ Coastal Hazard Guidance

¥ @3 Warning Polygons

> (] NOAA Polygons
Custom Polygons

Lon: | 152.42140°€ | Lat: | 3.17472°S Arrival: | 8.4 [hrs] Amp: | 6.2 [cm] Transparency: e )

Figure 12. Zoomed into a region of interest around Vanuatu in preparation to create a
Custom Coastal Hazard Polygon

The Custom Coastal Hazard Polygon dialog appears, with a default unique name. The
first step is to name this polygon with an appropriate name. We’ll choose “Vanuatu:
Tafea” by typing it into the Name box. Then we will click points surrounding the
islands; when we’re done, we’ll click “OK™ and the polygon will be rendered and added
to the “Tree” of Coastal Hazard Polygons on the map layers panel on the left (Figure 12).
The new Polygon will be rendered according to the Coastal Hazard within it, and updated
automatically. To delete the polygon, either right-click on its name in the layer list on the
left, or right-click directly on the polygon and select “Delete Polygon” (Figure 14). A
warning dialog will appear to confirm the deletion.
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eoce ‘TSUCAT version 1.1.1
File Edit Help

w Epicenter, Lat: Lon: [ 18800667 |
v T i Coastal A Tool wmw: Event:

Display Layers
@ I Wave Amplitude fcm)
& 2 Travel Time [hrs)
(] @ Earthquake Epicenters.
I Propagation Database
@ Nearest PropDB Epicenter
@ 7\ Coastal Hazard Guidance
@ B Countries
@ Place Names
& @3 Warning Polygons

> (] NOAA Polygons
¥ Custom Polygons.
™ Vanuatu: Tafea

Unit sources:

Name TAipha

aci6a 10.466
ac1sb 10.466
ac17a 10.466
a7 10.466
acisa 10.466
ac1sb 10.466
ac19a 10.466
ac10p 10.466
a0a 10.466

Lon: [ 15227657°E | Lat: | 5.92647°s | Amival: | 9.0 (hrs] Amp: | 220cm] |

Transparency: ()

Figure 13. A newly-created Custom Coastal Hazard Polygon named "Vanuatu: Tafea".

X0 TSuCAT version 1.1.1
File Edit Help

Epicenter, Lat Lon:
(A

i Coastal A Tool wmu: Event:

play Lay
& I Wave Amplitude [cm]
™ 2 Travel Time [hrs]

(] @ Earthquake Epicenters

¥ [ Propagation Database

¥ 7r Nearest PropDB Epicenter
& A\ Coastal Hazard Guidance
/B Countries

@ Place Names

&3 Warning Polygons

> ] NOA Polygons
v & Custom Polygons
™ Vanuatu: Tafea

Delete Waming Polygon?
name: Vanuatu

Unit Sources:

Lon: [ 170.48883°€ | Lat: [ 20.15593°s | Amival: [ 103(hrs] | Amp: [ S6lcm |

Transparency: et )

Figure 14: Deleting a Custom Coastal Hazard Polygon.
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The custom polygons are saved in Google Earth format (KML) in the application folder
in a file named “Custom_Warning_Polygons.kml”. Users can further edit the file by
locating it (select menu item “Help->View Application Folder” then open the folder
“etc”). Double-clicking the Custom Warning Polygons.kml file will launch the free
Google Earth application.

4.7 Other Features

Exporting Images

The user may export the TsuCAT map as a “PNG” image file by choosing the menu
“File->Export Map Image”.

Customizing Coastal Hazard Range Bins
The user may change the Coastal Hazard color bin cutoffs from the default values of 100
cm for “High” hazard, 30 cm for “Medium”, and 1 cm for “Low” hazard. These default

values are in use at NOAA’s Pacific Tsunami Warning Center, and the user can reset to
these values by pressing the User Preferences button “Reset to Defaults” (Figure 15).

Offshore Wave Amplitude Color Map

The user may choose between the NCTR color map, the MOST/SIFT color map used and
the PTWC Enhanced Products RIFT color map:

Offshore

(Wa\;e Ampl Offshore
4co"(‘) Offshore | :’:;‘;e Ampl
300 Wave Amp 300

200 [cm] ||

100 300 100

: -

& |
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File Edit View Help

Epicenter, Lat: | 38.29700 Lon: 142.37200

Vﬁ Tsunami Coastal Assessment Tool wmw: | 870 | Event:

Display Layers
~ I 1 Offshore Wave Ampl. [cm]
v 2 Travel Time [hrs]

| @ Earthquake Epicenters

V| r Nearest Source Epicenter
I] Tsunami Observations
& Plate Boundaries

Q

U ece TsuCAT User Preferences
- Use Internet Connection:  (s)
g Stream Map Tiles from Internet: (#) (must "Use Internet Connection" for this feature)
Set Map Tile Provider: () Open Street Map
| Clear Tile Cache | () Open Street Map H.O.T.
() ESRI World Topo
(®) ESRI National Greographic
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Coastal Hazard color bins: Offshore Wave Ampl Colormap:
High (default 100cm) | 1003 O NCTR
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@ PTWC
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Lon: L — P Y
B

Figure 15. TsuCAT User Preferences window allowing user to customize “Coastal
Hazard color bins,” select Wave Amplitude color map, and select Internet map streaming
using "View->Stream Map Tiles from Internet."

Additional Map Layers, Place Names

The requirement that this tool “stand alone” (work without an internet connection) gives
it the added benefit that it can be depended upon during an event, even if the only
information a user has is location and magnitude. However, there are two ways in which
an internet connection will make this tool even more useful.

The first is that the user may elect to load base-layer map image tiles by opening the User
Preferences dialog under “Edit->Preferences” (Figure 15). Background image “tiles”
then stream from a server as an online map would in a browser. This has the advantage
that place names are shown that might not show in the stand-alone database of places
(populations less than 15,000). The stand-alone place name database is used under
Creative Commons license from GeoNames.org.

If the user pans and zooms, new background imagery appropriate to that zoom level is
loaded, keeping the application more responsive, as the grey continents need not be
refreshed each time a user pans or zooms. The Provider for background tiles can be
selected for a different look to the basemap by choosing the User Preference “Set Map
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Tile Provider.” In addition to clear advantages of this feature, there are, however,
drawbacks that are described here. The first drawback is that the coastline for the Coastal
Hazard Guidance is still the medium-resolution GSHHS dataset. This means that if the
user zooms in very closely, e.g. to the island of Tahiti (Figure 16), the coarseness of the

coastline dataset is evident, though it is still of sufficient resolution to use as guidance at
the community level.

il el
Vm Tsunami Coastal Assessment Tool ww
PropDB: (14 466 +10.466"ac1 7b+10.4667ac1 8a+10.466"ac18b+ 10,

e |

08 ®&C

Vad
N

Figure 16. Using background image tiling to view CHG at Tahiti.

A second drawback is that if the user selects background image tiling, and the Offshore
Wave Amplitude layer, the Offshore Wave Amplitude tends to obscure the background
map. The way to mitigate this is to use the Transparency slider at the lower right to make
the wave amplitude transparent enough to see the place names.
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Figure 17. Using background image tiling with the Offshore Wave Amplitude layer and
transparency.
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Figure 18. Same as Figure 12, but with packaged gray coastal outlines.

The second feature available in TsuCAT is the ability to turn on and off the Place Names
layer. While selected, the 30 most populous city/town names are shown at any given
time. The packaged city/town names are those with populations greater than 15,000.
Since all of the country names are shown at all times, the map can get ‘crowded’ with
labels when zoomed all the way out. Please note that political borders (shown in blue)
also come from the GSHHS data set, and, therefore, do not always accurately reflect
current situations.
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Regional Reports

The ability to create a report of statistics including minimum/maximum offshore wave
amplitude and earliest/latest wave arrival times for a region has been added to TsuCAT.
The menu item “File->Export Regional Report” launches a dialog that asks the user to
first select a country from the drop-down list. This initializes the region. The user can
then zoom and pan to show the best effect of a given tsunami on the region, and the
statistics update as the user moves the map (Figure 19). The user can then edit the
“Region” name for the title of the report, and click “Generate” to save this as a file in the
application folder called “TsuCATReport.png” (Figure 20). Note that each time this
feature is used the file is over-written, so copy this file if you wish to save it.

00 Generate Regional Report
First Select Country: | Papua New Guinea
Region: Southwest Pacific

Then adjust map to region of interest and press "Generate":

Historical Earthquake info:
11 Mar 2011 05:46:00 (UTC) Mw: 9.1 Ep: 38.297° N, 142.372° E Dep: 30.0 [km] "JAPAN"

Region extents:
Latitude: 17.54304° S to 18.01252° S
Longitude: 128.00289° E to 175.69279° E

Wave Amplitude:
Minimum in Region, Offshore: 0.1 [cm], Coastal (CHG): 4.7 [cm]
Maximum in Region, Offshore: 198.1 [cm], Coastal (CHG): 530.3 [cm]

First Wave Arrival Time:
Earliest in Region: 2.4 [hours]
Latest in Region: 22.6 [hours]

Disclaimer:

Scenario based hazard assessment available through TsuCAT is primarily intended to support
pre-event tsunami response planning and exercise development. During an event, TsuCAT may
assist in early situational awareness (approximate scenario) prior to the availability of
event-snecific farecasts fram national aaencies ar internatinnal tsunami service nroviders

|
l | Generate

Figure 19: Regional Report creation, showing the dialog with statistic from the given
region.
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Tsunami Forecast Report: Southwest Pacific
Report generated from TsuCAT on 2017-11-07T11:08:37

Historical Earthquake info:
11 Mar 2011 05:46:00 (UTC) Mw: 9.1 Ep: 38.297° N, 142.372° E Dep: 30.0 [km] "JAPAN"

Region extents:
Latitude: 17.54304° S to 18.01252° S
Longitude: 128.00289° E to 175.69279° E

Wave Amplitude:
Minimum in Region, Offshore: 0.1 [cm], Coastal (CHG): 4.7 [cm]
Maximum in Region, Offshore: 198.1 [cm], Coastal (CHG): 530.3 [cm]

First Wave Arrival Time:
Earliest in Region: 2.4 [hours]
Latest in Region: 22.6 [hours]

Disclaimer:

Scenario based hazard assessment available through TsuCAT is primarily intended to support
pre-event tsunami response planning and exercise development. During an event, TsuCAT may
assist in early situational awareness (approximate scenario) prior to the availability of
event-specific forecasts from national agencies or international tsunami service providers.

Figure 20: Example report of the southwest Paciifc showing statistics from the effects of
the 2011 Japan tsunami on the region around Papua New Guinea.
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User-supplied Maps

The user can overlay a shapefile layer using the menu “File->Add/Remove User-supplied
Maps”. This feature allows loading an evacuation area map in GIS file (in shapefile
format) containing any polygon shapes OR from ComMIT by selecting a Composite
Wave File exported from ComMIT. TsuCAT can then render them as a colored, semi-
transparent layer. This feature is a convenient way to load Evacuation Maps. The user
simply clicks the “Add” button and navigates to their shapefile. The “Name” field is
initially set to the filename, but the user can edit this for convenience, and set the color
and transparency level. This file is then re-projected (if necessary) to WGS84 and saved

in the application “userMapOverlays” folder. Several shapefiles can be used in this way,
and TsuCAT will load them automatically each time it is run.

File Edit View Help

w Epicenter, Lat: | 38.29700 | Lon: | 142.37200

Tsunami Coastal Assessment Tool ww: | 910 | Event: 11 Mar 2011 05:46:00 (UTC) Mw: 9.1 Ep: 38.297° N, 142.3
ece

72° E Dep: 30.0 [km] "JAPAN"
Add Evacuation Map Shapefile

Display Layers Map shapefile overlays: | Oahu Map

¥ I 1 Offshore Wave Ampl. [cm] [ Add | | Remove |
v 2 Travel Time [hrs]

@ Earthquake Epicenters

Name: |Oahu Map
¥z Nearest Source Epicenter

(BRI EIEE“

Shapefile: OahuMap.shp
[ Tsunami Observations [2]

T

¥\ Plate Boundaries

71\ Coastal Hazard Guidance Color:

@ Place Names (ST HSV HSL | RGB | CMYK |
v & User-supplied Maps (shp)
&2 Warning Polygons
» [V PTWC Polygons
» ¥ Custom Polygons
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.

I Recent:
]

Preview
-] - W Sample Text Sample Text .
H=l Sample Text Sample Text

15-minute travel time contours
MOST model results

Lon 157.74154° W Lat 21.61465°N Arrival: | NaN [hrs] Ampl: | 32.9 [cm] Transparency:

Figure 21: Adding a user-supplied shapefile as a Map Layer.
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Generating Exercise Messages

New with version 4.0 is the capability of producing messages that mimic the PTWC text
and graphical products to assist in preparing for national and regional tsunami exercises
such as the PacWave and CaribeWave. For these exercises, PTWC generates sets of
regional or basin-wide products for a simulated event to aid in training for response to an
actual event. TsuCAT is similarly able to produce sets of PTWC Tsunami Threat
Messages or Information Statements appropriate for the earthquake parameters and for
PTWC’s procedures and protocols. TsuCAT includes in the messages simulated tsunami
wave measurements at coastal and deep ocean sea level gauges.

To use this new feature, the user simply chooses an event (either by selected from the
historical database or by moving the epicenter and typing in a magnitude). Then, from
the File menu, the user chooses “Generate Exercise Messages”. This brings up the dialog
window (Figure 22), adjusts the date of the Exercise, and presses the “Generate” button:

[ ] [ ] Export Exercise Messages

Mag: 8.8 Epicenter: 49.089°N, 176.138°W

Adjust for date of Exercise: 03/30/2019 19:47 ° Generate <- Press Generate

Graphic Products

Figure 22: The TsuCAT "Export Exercise Messages" dialog.



Tsunami Coastal Assessment Tool User’s Manual 33

The window has a status/progress bar along the bottom, which shows “...analyzing...”,
and the progress it makes. This feature is a fairly intensive process and typically takes
anywhere from 30 seconds to two minutes. When it completes, the text bulletin
Messages are shown on the tab titled “Messages” and the Enhanced Graphical Products
and shown in the tab titled “Graphical Products™:

‘o0 @ Export Exercise Messages

Mag: 8.8 Epicenter: 49.089°N, 176.138°W
Adjust for date of Exercise: 03/30/2019 19:47 * GCenerate 00:06 Message 1 00:24 Coastal Tsunami Amplitude

Messages
PTWC Coastal Tsunami Amplitude Forecast

Actual amplitudes at the coast may vary from forecast amplitudes due to uncertainties
in the forecast and local features. In particular, maximum tsunami amplitudes on atolls
and at locations with fringing or barrier reefs will likely be much smaller than the
forecast indicates.

This message is issued for information only in support of the UNESCO/IOC Pacific
Tsunami Warning and Mitigation System and is meant for national authorities in
each country of that system. National authorities will determine the appropriate
level of alert for each country and may issue additional or more refined information.

Earthquake:
08 Sep 2017
04:49:46 Z
Lat: 14.99°N
Lon: 94.85°W
Depth: 11 km
Mw: 8.80

Determined
Earthquake Q
Mechanism:

Maximum
Amplitude (m)
460

1.00

Open Messages Folder

Figure 23: The Export Exercise Messages window, with a Coastal Tsunami Forecast
graphic from the Enhanced Products showing.

The user can select the Messages or the Graphical Products to view by clicking on the
drop-down list. The lists show the simulated Event Time they were produced for in
hours:minutes, and a description (e.g. “00:30 Message 2”). Just as PTWC produces
updates for real events every hour, so do TsuCAT ... the total event time is calculated as
the time it takes for waves to fall below 30 centimeters, and for a typical basin-scale
MB8.0 event is anywhere from 6 to 18 hours depending on epicenter location.
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The user can click on the “Open Messages Folder” button at the button (Figure 23) to
view “hard copies” of the products in the format typically dispersed by PTWC for
exercises: Messages in Rich Text Format (RTF), and Graphical Products in Portable
Network Graphics (PNG) format. A typical Tsunami Threat Message is shown below
(Figure 24) for an M8.8 event in the Aleutian Islands. Information about the forecast and
countries affected are listed, as well as Estimated Times of Arrival and Potential Impacts.
Messages are updated hourly until the event is over.

When using the TsuCAT PTWC Exercise Text Message feature, please be aware that
even though a real tsunami event can be selected from the Global Historical Tsunami
Database, the source that TsuCAT uses is the closest source in the TsuCAT catalog and
Text Messages and Graphical Products produced may not exactly match those PTWC
produced for the event. In most cases, TsuCAT will produce slightly higher wave
amplitudes.

For more information on the PTWC Enhanced Products, refer to IOC Technical Series
no. 105 (rev), User’s Guide for the PTWC Enhanced Products for the PTWS (Aug 2014,
English, Spanish), or visit the PTWC New Enhanced Products website

http://itic.ioc-
unesco.org/index.php?option=com_content&view=category&layout=blog&id=2143&Ite
mid=2582

or the Users Guide

For more information on Tsunami Exercises, please visit the ITIC website on Tsunami
Exercises, http://itic.ioc-
unesco.org/index.php?option=com_content&view=category&layout=blog&id=1439&Ite
mid=1439
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TEST...TSUNAMI MESSAGE NUMBER 2...TEST

NWS PACIFIC TSUNAMI WARNING CENTER EWA BEACH HI

2002 UTC SAT MAR 30 2019

...THIS MESSAGE IS FOR TEST PURPOSES ONLY...

««.TEST PTWC TSUNAMI THREAT MESSAGE TEST...

*x2* NOTICE **** NOTICE t*t*** NOTICE t*** NOTICE *t*** NOTICE ttt==*
THIS MESSAGE IS ISSUED FOR INFORMATION ONLY IN SUPPORT OF THE
UNESCO/IOC PACIFIC TSUNAMI WARNING AND MITIGATION SYSTEM AND IS
MEANT FOR NATIONAL AUTHORITIES IN EACH COUNTRY OF THAT SYSTEM.
NATIONAL AUTHORITIES WILL DETERMINE THE APPROPRIATE LEVEL OF
ALERT FOR EACH COUNTRY AND MAY ISSUE ADDITIONAL OR MORE REFINED
INFORMATION.

*t** NOTICE =*** NOTICE t*=*** NOTICE t*t*** NOTICE tt*** NOTICE ttt=:=®
THE TSUNAMI FORECAST IS UPDATED IN THIS MESSAGE.

NOTE EARTHQUAKE MAGNITUDE UPGRADED.

TEST... PRELIMINARY EARTHQUAKE PARAMETERS ...TEST

* MAGNITUDE 8.8

* ORIGIN TIME 1947 UTC SAT MAR 30 2019

* COORDINATES 49.1 NORTH 176.1 EAST

* DEPTH 11 / 7 MILES

* LOCATION SOUTH OF THE ALEUTIAN ISLANDS

TEST... EVALUATION ...TEST

* AN EARTHQUAKE WITH A PRELIMINARY MAGNITUDE OF 8.8 OCCURRED
SOUTH OF THE ALEUTIAN ISLANDS AT 1947 UTC SATURDAY
MARCH 30 2019

* THIS IS A TEST MESSAGE.

* BASED ON ALL AVAILABLE DATA... HAZARDOUS TSUNAMI WAVES ARE
FORECAST FOR SOME COASTS.

TEST... TSUNAMI THREAT FORECAST...UPDATED ...TEST

* TSUNAMI WAVES REACHING MORE THAN 3 METERS ABOVE THE TIDE
LEVEL ARE POSSIBLE ALONG SOME COASTS OF

MIDWAY ISLAND AND NORTHWEST HAWAII.

* TSUNAMI WAVES REACHING 1 to 3 METERS ABOVE THE TIDE
LEVEL ARE POSSIBLE ALONG SOME COASTS OF

ALASKA... BIG ISLAND... HAWAII... HOWLAND AND BAKER...
JOHNSTON ISLAND... KAUAI... KIRIBATI...

MAUI... MOLOKAI... NIIHAU... OAHU... RUSSIA...

SAMOA AND SOLOMON ISLANDS.

* TSUNAMI WAVES REACHING 0.3 TO 1 METERS ABOVE THE TIDE LEVEL
ARE POSSIBLE FOR SOME COASTS OF

AMERICAN SAMOA... AUNUU... CALIFORNIA... CANADA...
CHILE... CHUUK... CNMI... COOK ISLANDS... ECUADOR...
FRENCH POLYNESIA... GUAM... INDONESIA...

JAPAN... JARVIS ISLAND... KOSRAE... LANAI...

MANUA... MARSHALL ISLANDS... MEXICO... MINAMITORISHIMA...
NAURU... NEW ZEALAND... NIUE...

Figure 24: Typical Tsunami Threat Message issued from TsuCAT.
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Seismic Expert Regional Sources

Through a collaboration with UNESCO’s Intergovernmental Oceanographic Commission
(I0C), a series of workshops were held with the goal of identifying regional seismic
sources that represent the credible tsunami sources with potential impact for regional
coastlines. The workshops were held in Haiti (2013), Xiamen, China (2015), Costa Rica
(2016), Dominican Republic (2016), and New Zealand (2017), and defined a series of
sources for the Caribbean Sea, Central/South America, Tonga Trench and the South
China Sea. Sources from these workshops were published in Workshop Reports (pdf
files of these reports can be found in the TsuCAT/eventSources folder). The source
parameters published in these reports were named using the report source name, run with
MOST/RIFT models, and made available through the “File->Select Expert Regional
Source” feature (Figure 25). The maximum offshore wave amplitude, arrival time, and
coastal amplitude are then accessible in the same way as any other source in TsuCAT.
Fault plane parameters from these sources (or any other) can be used in ComMIT by
using the “View->Fault Information for ComMIT” feature.

e0e TsuCAT version 4.1
File Edit View Help

Epicenter, Lat: = 9.88674 Lon: 274.74274

Tsunami Coastal Assessment Tool mw: | 812 Event: Seismic Expert Source, I0C Report WR-278, source: Nicobano

9

—ece Open
| =
[ eventSources
Name | Date Modified [
9 CentSouth_DOM_h.nc Tuesday, September 3,2019 2:21 ...
3, CentSouth_Guanica_h.nc Tuesday, September 3, 2019 2:21 ...
B CentSouth Nicobano_h.nc Tuesday, September 3, 2019 2:21 ...
9, CentSouth_OSA_h.nc Tuesday, September 3,2019 2:21 ...
9 ChinaSea_Phil_1_h.nc Tuesday, September 3,2019 2:21 ...
9, ChinaSea_Phil_2_h.nc Tuesday, September 3,2019 2:21 ...

9 ChinaSea_Phil_4_h.nc Tuesday, September 3,2019 2:21 ...

& ChinaSea_Phil_3_h.nc Tuesday, September 3,2019 2:21 ...

9 ChinaSea_Phil_5_h.nc Tuesday, September 3,2019 2:21 ...
9 ChinaSea_Phil_6_h.nc Tuesday, September 3,2019 2:21 ...
& ChinaSea_Phil_7_h.nc Tuesday, September 3, 2019 2:21 ...
9 DomRep_MEF_h.nc Tuesday, September 3,2019 2:21 ...
3, DomRen MS_h.nc Tuesdav. 3.20192:21

File Format: _All Files B

Cancel

|
| Lon: 167.08701°E Lat: 27.10589° N Arrival:  14.47 [hrs] Offshore Ampl: 0.5 [cm] T

Figure 25: Seismic Expert Source loading in TsuCAT (File->Select Expert Regional
Source)
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